re = /!pybot (.*?) /m
str = '!pybot run ```
print("passionbaby")
asd
asd
asd
as
das
d
ad
as
d
as
d
as
d
sa
das
d
sa
d
\\` \\`
```'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end