import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "!pybot (.*?) ";
final String string = "!pybot run ```\n"
+ "print(\"passionbaby\")\n"
+ "asd\n"
+ "asd\n"
+ "asd\n\n"
+ "as\n"
+ "das\n"
+ "d\n"
+ "ad\n"
+ "as\n"
+ "d\n"
+ "as\n"
+ "d\n\n"
+ "as\n"
+ "d\n"
+ "sa\n"
+ "das\n"
+ "d\n"
+ "sa\n"
+ "d\n"
+ "\\` \\`\n"
+ "```";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}