import re
regex = re.compile(r"album_release_date: \"(.*?)\"", flags=re.MULTILINE)
test_str = ("\n"
"var TralbumData = {\n\n"
" current: {\n"
" \"upc\":null,\"title\":\"BLACK&WHITE MEDICINE\",\"purchase_title\":null,\n"
" \"download_desc_id\":null,\"minimum_price\":0.0,\"set_price\":7.0,\"mod_date\":\"17 Jun 2018 11:47:50 GMT\"\n"
" },\n"
" album_is_preorder: null,\n"
" album_release_date: \"17 Jun 2018 00:00:00 GMT\",\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")