use strict;
my $str = 'http://gioplet/articles
http://gioplet/img/logo.png
http://gioplet/index.php
http://gioplet/css/main.css
http://gioplet/.css/main
http://gioplet/.png/main
http://gioplet/main/index.html
http://gioplet/js/main.js';
my $regex = qr/$(?<!\.(?:ico|gif|jpg|png|css|rss|xml|htm|pdf|zip|txt|ttf)$|(?:js|gz)$|(?:html|woff)$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}