$re = '/$(?<!\.(?:ico|gif|jpg|png|css|rss|xml|htm|pdf|zip|txt|ttf)$|(?:js|gz)$|(?:html|woff)$)/m';
$str = 'http://gioplet/articles
http://gioplet/img/logo.png
http://gioplet/index.php
http://gioplet/css/main.css
http://gioplet/.css/main
http://gioplet/.png/main
http://gioplet/main/index.html
http://gioplet/js/main.js';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);