re = /$(?<!\.(?:ico|gif|jpg|png|css|rss|xml|htm|pdf|zip|txt|ttf)$|(?:js|gz)$|(?:html|woff)$)/m
str = 'http://gioplet/articles
http://gioplet/img/logo.png
http://gioplet/index.php
http://gioplet/css/main.css
http://gioplet/.css/main
http://gioplet/.png/main
http://gioplet/main/index.html
http://gioplet/js/main.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end