import re
regex = re.compile(r"$(?<!\.(?:ico|gif|jpg|png|css|rss|xml|htm|pdf|zip|txt|ttf)$|(?:js|gz)$|(?:html|woff)$)", flags=re.MULTILINE)
test_str = ("http://gioplet/articles\n"
"http://gioplet/img/logo.png\n"
"http://gioplet/index.php\n"
"http://gioplet/css/main.css\n"
"http://gioplet/.css/main\n"
"http://gioplet/.png/main\n"
"http://gioplet/main/index.html\n"
"http://gioplet/js/main.js")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")