# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d*(\(\d+\))\d*/$1/gm;t' <<< "0000(10)0000
0(16)5000000
021(10)0000(11)
"