const regex = /\d*(\(\d+\))\d*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d*(\\(\\d+\\))\\d*', 'gm')
const str = `0000(10)0000
0(16)5000000
021(10)0000(11)
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);