using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d*(\(\d+\))\d*";
string substitution = @"$1";
string input = @"0000(10)0000
0(16)5000000
021(10)0000(11)
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}