$re = '/\d*(\(\d+\))\d*/m';
$str = '0000(10)0000
0(16)5000000
021(10)0000(11)
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;