#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d*(\(\d+\))\d*"
Local $sString = "0000(10)0000" & @CRLF & _
"0(16)5000000" & @CRLF & _
"021(10)0000(11)" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)