const regex = /CONTEXT_MANAGER_ALARM_WAKEUP_[0-9]{4,}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('CONTEXT_MANAGER_ALARM_WAKEUP_[0-9]{4,}', '')
const str = `CONTEXT_MANAGER_ALARM_WAKEUP_2151111113123122132134535342524364542142`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}