// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"CONTEXT_MANAGER_ALARM_WAKEUP_[0-9]{4,}").unwrap();
let string = "CONTEXT_MANAGER_ALARM_WAKEUP_2151111113123122132134535342524364542142";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}