re = /CONTEXT_MANAGER_ALARM_WAKEUP_[0-9]{4,}/
str = 'CONTEXT_MANAGER_ALARM_WAKEUP_2151111113123122132134535342524364542142'
# Print the match result
str.match(re) do |match|
puts match.to_s
end