$re = '/CONTEXT_MANAGER_ALARM_WAKEUP_[0-9]{4,}/';
$str = 'CONTEXT_MANAGER_ALARM_WAKEUP_2151111113123122132134535342524364542142';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);