#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[-x+]\h*may(?:15)?(*SKIP)(*F)|may(?:15)?"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"x May15 > WRONG" & @CRLF & _
"- May15 > WRONG" & @CRLF & _
"+ May15 > WRONG" & @CRLF & _
"xMay15 > WRONG" & @CRLF & _
"-May15 > WRONG" & @CRLF & _
"+May15 > WRONG" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"TRADED; Mar15 x May15, 5 MW Base 121,50 TL may"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")