const regex = /[-x+]\h*may(?:15)?(*SKIP)(*F)|may(?:15)?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[-x+]\\h*may(?:15)?(*SKIP)(*F)|may(?:15)?', 'gi')
const str = `
x May15 > WRONG
- May15 > WRONG
+ May15 > WRONG
xMay15 > WRONG
-May15 > WRONG
+May15 > WRONG
TRADED; Mar15 x May15, 5 MW Base 121,50 TL may`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}