package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[-x+]\h*may(?:15)?(*SKIP)(*F)|may(?:15)?`)
var str = `
x May15 > WRONG
- May15 > WRONG
+ May15 > WRONG
xMay15 > WRONG
-May15 > WRONG
+May15 > WRONG
TRADED; Mar15 x May15, 5 MW Base 121,50 TL may`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}