re = /[-x+]\h*may(?:15)?(*SKIP)(*F)|may(?:15)?/i
str = '
x May15 > WRONG
- May15 > WRONG
+ May15 > WRONG
xMay15 > WRONG
-May15 > WRONG
+May15 > WRONG
TRADED; Mar15 x May15, 5 MW Base 121,50 TL may'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end