$re = '/[-x+]\h*may(?:15)?(*SKIP)(*F)|may(?:15)?/i';
$str = '
x May15 > WRONG
- May15 > WRONG
+ May15 > WRONG
xMay15 > WRONG
-May15 > WRONG
+May15 > WRONG
TRADED; Mar15 x May15, 5 MW Base 121,50 TL may';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);