# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)\((.*)\) (.*)/$3/;t' <<< "Terence DEMOL (Je dois supprimer à partir de ce message) 06 95 93 94 59"