use strict;
my $str = 'Terence DEMOL (Je dois supprimer à partir de ce message) 06 95 93 94 59';
my $regex = qr/(.*)\((.*)\) (.*)/p;
my $subst = '$3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";