import Foundation
let pattern = #"(.*)\((.*)\) (.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Terence DEMOL (Je dois supprimer à partir de ce message) 06 95 93 94 59"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}