#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.*)\((.*)\) (.*)"
Local $sString = "Terence DEMOL (Je dois supprimer à partir de ce message) 06 95 93 94 59"
Local $sSubst = "$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)