# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s+(?=[^.,\s])|\b(?:\s+|(?=[,.]))|(?<=[,.])\b/\n/gu;t' <<< "This, I think,., کباب MAKES , some sense
This, I think,. , کباب MAKES , some sense
This, I think,. , کباب MAKES , some sense
This, I think, . ,کباب MAKES , some sense
"