import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+(?=[^.,\\s])|\\b(?:\\s+|(?=[,.]))|(?<=[,.])\\b";
final String string = "This, I think,., کباب MAKES , some sense \n"
+ "This, I think,. , کباب MAKES , some sense \n"
+ "This, I think,. , کباب MAKES , some sense \n"
+ "This, I think, . ,کباب MAKES , some sense \n";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}