const regex = /\s+(?=[^.,\s])|\b(?:\s+|(?=[,.]))|(?<=[,.])\b/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+(?=[^.,\\s])|\\b(?:\\s+|(?=[,.]))|(?<=[,.])\\b', 'gu')
const str = `This, I think,., کباب MAKES , some sense
This, I think,. , کباب MAKES , some sense
This, I think,. , کباب MAKES , some sense
This, I think, . ,کباب MAKES , some sense
`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);