re = /\s+(?=[^.,\s])|\b(?:\s+|(?=[,.]))|(?<=[,.])\b/
str = 'This, I think,., کباب MAKES , some sense
This, I think,. , کباب MAKES , some sense
This, I think,. , کباب MAKES , some sense
This, I think, . ,کباب MAKES , some sense
'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result