use strict;
my $str = 'This, I think,., کباب MAKES , some sense
This, I think,. , کباب MAKES , some sense
This, I think,. , کباب MAKES , some sense
This, I think, . ,کباب MAKES , some sense
';
my $regex = qr/\s+(?=[^.,\s])|\b(?:\s+|(?=[,.]))|(?<=[,.])\b/up;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";