import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "export\\s+async\\s+function\\s+generateMetadata\\s*\\(\\s*\\{[\\s\\S]*?\\}\\s*\\):\\s*Promise<Metadata>\\s*\\{\\s*const\\s*\\{\\s*t\\s*\\}\\s*=\\s*await\\s*translationServer\\s*\\(\\s*locale\\s*,\\s*'projectTitles'\\s*\\);\\s*return\\s*\\{\\s*title\\s*:\\s*translate\\s*\\}?\\s*\\}";
final String string = "import { Metadata } from 'next';\n\n"
+ "import CreateEnactment from './_components';\n"
+ "import { translationServer } from 'i18n';\n"
+ "import { hasPermissionServerSide } from 'utils';\n\n"
+ "const CreateEnactmentPage = async () => {\n"
+ " await hasPermissionServerSide({ branchRoles: ['ADMIN', 'OPERATOR'] });\n\n"
+ " return <CreateEnactment />;\n"
+ "};\n\n"
+ "export async function generateMetadata({ params: { locale, enactmentId } }: { params: Params }): Promise<Metadata> {\n"
+ " const { t } = await translationServer(locale, 'projectTitles');\n\n"
+ " const translate = enactmentId === 'new-enactment' ? t('newEnactment') : t('viewEnactment');\n\n"
+ " // to meta tag\n"
+ " return {\n"
+ " title: translate\n"
+ " };\n"
+ "}\n\n"
+ "export default CreateEnactmentPage;\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}