import Foundation
let pattern = #"export\s+async\s+function\s+generateMetadata\s*\(\s*\{[\s\S]*?\}\s*\):\s*Promise<Metadata>\s*{\s*const\s*\{\s*t\s*\}\s*=\s*await\s*translationServer\s*\(\s*locale\s*,\s*'projectTitles'\s*\);\s*return\s*\{\s*title\s*:\s*translate\s*\}?\s*}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
import { Metadata } from 'next';
import CreateEnactment from './_components';
import { translationServer } from 'i18n';
import { hasPermissionServerSide } from 'utils';
const CreateEnactmentPage = async () => {
await hasPermissionServerSide({ branchRoles: ['ADMIN', 'OPERATOR'] });
return <CreateEnactment />;
};
export async function generateMetadata({ params: { locale, enactmentId } }: { params: Params }): Promise<Metadata> {
const { t } = await translationServer(locale, 'projectTitles');
const translate = enactmentId === 'new-enactment' ? t('newEnactment') : t('viewEnactment');
// to meta tag
return {
title: translate
};
}
export default CreateEnactmentPage;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}