use strict;
my $str = 'import { Metadata } from \'next\';
import CreateEnactment from \'./_components\';
import { translationServer } from \'i18n\';
import { hasPermissionServerSide } from \'utils\';
const CreateEnactmentPage = async () => {
await hasPermissionServerSide({ branchRoles: [\'ADMIN\', \'OPERATOR\'] });
return <CreateEnactment />;
};
export async function generateMetadata({ params: { locale, enactmentId } }: { params: Params }): Promise<Metadata> {
const { t } = await translationServer(locale, \'projectTitles\');
const translate = enactmentId === \'new-enactment\' ? t(\'newEnactment\') : t(\'viewEnactment\');
// to meta tag
return {
title: translate
};
}
export default CreateEnactmentPage;
';
my $regex = qr/export\s+async\s+function\s+generateMetadata\s*\(\s*\{[\s\S]*?\}\s*\):\s*Promise<Metadata>\s*{\s*const\s*\{\s*t\s*\}\s*=\s*await\s*translationServer\s*\(\s*locale\s*,\s*'projectTitles'\s*\);\s*return\s*\{\s*title\s*:\s*translate\s*\}?\s*}/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}