$re = '/export\s+async\s+function\s+generateMetadata\s*\(\s*\{[\s\S]*?\}\s*\):\s*Promise<Metadata>\s*{\s*const\s*\{\s*t\s*\}\s*=\s*await\s*translationServer\s*\(\s*locale\s*,\s*\'projectTitles\'\s*\);\s*return\s*\{\s*title\s*:\s*translate\s*\}?\s*}/';
$str = 'import { Metadata } from \'next\';
import CreateEnactment from \'./_components\';
import { translationServer } from \'i18n\';
import { hasPermissionServerSide } from \'utils\';
const CreateEnactmentPage = async () => {
await hasPermissionServerSide({ branchRoles: [\'ADMIN\', \'OPERATOR\'] });
return <CreateEnactment />;
};
export async function generateMetadata({ params: { locale, enactmentId } }: { params: Params }): Promise<Metadata> {
const { t } = await translationServer(locale, \'projectTitles\');
const translate = enactmentId === \'new-enactment\' ? t(\'newEnactment\') : t(\'viewEnactment\');
// to meta tag
return {
title: translate
};
}
export default CreateEnactmentPage;
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);