package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a\b\s*[^<>]*\bmailto\b[^<>]*>([^<>]*)<\/a>`)
var str = `Visit <a href="http://www.flexstaff.com">www.flexstaff.com</a> for details
Email <a href="mailto:rachel@flexstaff.com">rachel@flexstaff.com</a> apply online.`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}