re = /<a\b\s*[^<>]*\bmailto\b[^<>]*>([^<>]*)<\/a>/m
str = 'Visit <a href="http://www.flexstaff.com">www.flexstaff.com</a> for details
Email <a href="mailto:rachel@flexstaff.com">rachel@flexstaff.com</a> apply online.'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result