const regex = /<a\b\s*[^<>]*\bmailto\b[^<>]*>([^<>]*)<\/a>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a\\b\\s*[^<>]*\\bmailto\\b[^<>]*>([^<>]*)<\\\/a>', 'gm')
const str = `Visit <a href="http://www.flexstaff.com">www.flexstaff.com</a> for details
Email <a href="mailto:rachel@flexstaff.com">rachel@flexstaff.com</a> apply online.`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);