$re = '/<a\b\s*[^<>]*\bmailto\b[^<>]*>([^<>]*)<\/a>/m';
$str = 'Visit <a href="http://www.flexstaff.com">www.flexstaff.com</a> for details
Email <a href="mailto:rachel@flexstaff.com">rachel@flexstaff.com</a> apply online.';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;