import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\b\\s*[^<>]*\\bmailto\\b[^<>]*>([^<>]*)<\\/a>";
final String string = "Visit <a href=\"http://www.flexstaff.com\">www.flexstaff.com</a> for details\n"
+ " Email <a href=\"mailto:rachel@flexstaff.com\">rachel@flexstaff.com</a> apply online.";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}