using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^width:\s*(?:calc\()?(?:[0-9]+(?:p[ctx]|e[mx]|%|in|[cm]m)[\s+-]*)+\)?";
string input = @"width: 55px
width: calc(100% - 10px)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}