package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^width:\s*(?:calc\()?(?:[0-9]+(?:p[ctx]|e[mx]|%|in|[cm]m)[\s+-]*)+\)?`)
var str = `width: 55px
width: calc(100% - 10px)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}