re = /^width:\s*(?:calc\()?(?:[0-9]+(?:p[ctx]|e[mx]|%|in|[cm]m)[\s+-]*)+\)?/m
str = 'width: 55px
width: calc(100% - 10px)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end