import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^width:\\s*(?:calc\\()?(?:[0-9]+(?:p[ctx]|e[mx]|%|in|[cm]m)[\\s+-]*)+\\)?";
final String string = "width: 55px\n"
+ "width: calc(100% - 10px)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}