const regex = /^width:\s*(?:calc\()?(?:[0-9]+(?:p[ctx]|e[mx]|%|in|[cm]m)[\s+-]*)+\)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^width:\\s*(?:calc\\()?(?:[0-9]+(?:p[ctx]|e[mx]|%|in|[cm]m)[\\s+-]*)+\\)?', 'gm')
const str = `width: 55px
width: calc(100% - 10px)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}