$re = '/([01]?[0-9]|2[0-3])(-([01]?[0-9]|2[0-3])(\/[0-9]*)?)?(,([01]?[0-9]|2[0-3])(-([01]?[0-9]|2[0-3])(\/[0-9]*)?)?)*/';
$str = '1-2/9,2-3/33,5,6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);