re = /\['.*?',\s*(.*?)\]/m
str = '[\'WRK\', \'SOCCER\', \'CHILD\']
[\'FIN\', \'TENNIS\', \'CHILD\']
[\'WRK\', \'GOLF\', \'CHILD\']'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result