#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^|abc)(?:(?!abc).)+"
Local $sString = "abbacaba" & @CRLF & _
"ddabcdd" & @CRLF & _
"ddabcddddabcdd" & @CRLF & _
"ddabcddddabc" & @CRLF & _
"abcddddabcdd" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ddabcabcddddabcdd" & @CRLF & _
"abcabcddddabcdd" & @CRLF & _
"ddabcabcddddabcabc" & @CRLF & _
"" & @CRLF & _
"ddabcabcabddddabcdd" & @CRLF & _
"abcabcabddddabcdd" & @CRLF & _
"ddabcabcddddabcabcab" & @CRLF & _
"" & @CRLF & _
"ddabcababcddddabcabcab"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")