using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|abc)(?:(?!abc).)+";
string input = @"abbacaba
ddabcdd
ddabcddddabcdd
ddabcddddabc
abcddddabcdd
ddabcabcddddabcdd
abcabcddddabcdd
ddabcabcddddabcabc
ddabcabcabddddabcdd
abcabcabddddabcdd
ddabcabcddddabcabcab
ddabcababcddddabcabcab";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}