import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|abc)(?:(?!abc).)+";
final String string = "abbacaba\n"
+ "ddabcdd\n"
+ "ddabcddddabcdd\n"
+ "ddabcddddabc\n"
+ "abcddddabcdd\n\n\n"
+ "ddabcabcddddabcdd\n"
+ "abcabcddddabcdd\n"
+ "ddabcabcddddabcabc\n\n"
+ "ddabcabcabddddabcdd\n"
+ "abcabcabddddabcdd\n"
+ "ddabcabcddddabcabcab\n\n"
+ "ddabcababcddddabcabcab";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}