re = /(?<=^|abc)(?:(?!abc).)+/m
str = 'abbacaba
ddabcdd
ddabcddddabcdd
ddabcddddabc
abcddddabcdd
ddabcabcddddabcdd
abcabcddddabcdd
ddabcabcddddabcabc
ddabcabcabddddabcdd
abcabcabddddabcdd
ddabcabcddddabcabcab
ddabcababcddddabcabcab'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end